The PPD version is not compatible with Gutenprint

После обновления системы при попытке отправить на печать документы cups отписывался
"The PPD version (5.2.10) is not compatible with Gutenprint 5.2.11."

Корень проблемы в пакетах – они должны быть упорядочены после обновления. Обновлять командой под рутом

$ sudo /usr/sbin/cups-genppdupdate

Проблема заключается в том, что файлы Gutenprint PPD аттачены к версии гутенпринта для которой они генерировались. Потому что настройки могут меняться от релиза к релизу и мы должны быть уверены, что PPD файлы будут синхронизированы. Программа cups-genppdupdate обновляет все установленные Gutenprint PPD файлы.

После обновления нужно перезапустить демона.

$ sudo systemctl restart cups.service

Комментарии

Добавить комментарий