Profile picture for user admin_romcom

Сегодня впервые за много лет пользования Линукс, у меня не получилось распаковать rar файл!

оказывается, версия unrar-free не умеет распаковывать файлы RAR версии выше 3.x. Хотя при листинге файлов мне писало версию 2.9. Ладно

$ sudo apt-get purge unrar-free

Чтоб установить unrar-nonfree через apt нужно добавить non-free ключ к репам. Но мне было лень. Скачать нужную версию можно тут:

https://launchpad.net/ubuntu/+source/unrar-nonfree

Нужную, потому что скачав последнюю мне выдало

dpkg: dependency problems prevent configuration of unrar:
 unrar depends on libstdc++6 (>= 5); however:
  Version of libstdc++6:i386 on system is 4.9.2-10.

Я не стал парится и просто сделал

$ wget https://launchpadlibrarian.net/154812330/unrar_5.0.10-1_i386.deb
$ sudo dpkg -i unrar_5.0.10-1_i386.deb

Теперь набрав команду

$ unrar e my_file.rar ~/save_here

архив успешно распаковался.

Добавить комментарий

The content of this field is kept private and will not be shown publicly.
  • No HTML tags allowed.
 o---o  o--o   o--o   o-o     o-o  
/ | | | | | \ | o
-O- O--o O-Oo | O o--O
/ | | \ | / /
o---o o o o o-o o

Enter the code depicted in ASCII art style.